Affected versions of react-dom are vulnerable to Cross-Site Scripting (XSS). The package fails to validate attribute names in HTML tags which may lead to Cross-Site Scripting in specific scenarios. This may allow attackers to execute arbitrary JavaScript in the victim's browser. To be affected by this vulnerability, the application needs to:
be a server-side React app
be rendered to HTML using ReactDOMServer
include an attribute name from user input in an HTML tag
// recommendation
If you are using react-dom 16.0.x, upgrade to 16.0.1 or later. If you are using react-dom 16.1.x, upgrade to 16.1.2 or later. If you are using react-dom 16.2.x, upgrade to 16.2.1 or later. If you are using react-dom 16.3.x, upgrade to 16.3.3 or later. If you are using react-dom 16.4.x, upgrade to 16.4.2 or later.
// cvss v3.0 vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None
Checked 2026-11-06 at 22:22 UTC. The most recent advisory here was published 2019-01-04. Updated continuously from NVD, GHSA, OSV and CNA feeds.