npm package report

Is https-proxy-agent safe?

2 known vulnerabilities, worst severity CRITICAL.

// reach

4 direct dependencies

2 carry known advisories, worst HIGH

157 packages depend on it

an advisory here reaches each of them

  • @asyncapi/cli
  • cy2
Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


cvss
9.1
critical

CVSS v3.0 base score out of 10

epss
1.7%
medium

chance of exploitation in 30 days, 78th percentile of all CVEs

xyz score
5.5
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-8g7p-74h8-hg48, the advisory selected below

// 2 advisories

GHSA-8g7p-74h8-hg48

CRITICALGitHub ratingCVE-2018-3739

Versions of https-proxy-agent before 2.2.0 are vulnerable to denial of service. This is due to unsanitized options (proxy.auth) being passed to Buffer().

// recommendation

Update to version 2.2.0 or later.

// cvss v3.0 vector

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
High

Checked 2026-11-06 at 18:17 UTC. The most recent advisory here was published 2020-04-16. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.