npm package report

Is extend safe?

1 known vulnerability, worst severity MODERATE.

// reach

0 direct dependencies

none carry a known advisory

    110 packages depend on it

    an advisory here reaches each of them

    Create a free accountfor every dependency path, dependent and what to upgrade
    // ai model usage

    Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


    cvss
    5.0
    medium

    severity band, no base score published

    epss
    3.0%
    medium

    chance of exploitation in 30 days, 88th percentile of all CVEs

    xyz score
    not scored

    CyberXYZ composite out of 10

    fig. 01 — GHSA-qrmc-fj45-qfc2, the advisory selected below

    // 1 advisories

    GHSA-qrmc-fj45-qfc2

    MODERATEGitHub ratingCVE-2018-16492

    Versions of extend prior to 3.0.2 (for 3.x) and 2.0.2 (for 2.x) are vulnerable to Prototype Pollution. The extend() function allows attackers to modify the prototype of Object causing the addition or modification of an existing property that will exist on all objects.

    // recommendation

    If you're using extend 3.x upgrade to 3.0.2 or later. If you're using extend 2.x upgrade to 2.0.2 or later.


    Checked 2026-11-06 at 19:12 UTC. The most recent advisory here was published 2019-02-07. Updated continuously from NVD, GHSA, OSV and CNA feeds.

    Think a verdict here is wrong? Tell us — we respond within 2 business days.