npm package report

Is http-proxy safe?

2 known vulnerabilities, worst severity HIGH.

// reach

8 direct dependencies

3 carry known advisories, worst HIGH

72 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


cvss
7.5
high

CVSS v3.1 base score out of 10

epss
not scored

chance of exploitation in 30 days

xyz score
4.7
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-6x33-pw7p-hmpq, the advisory selected below

// 2 advisories

GHSA-6x33-pw7p-hmpq

HIGHGitHub rating

Versions of http-proxy prior to 1.18.1 are vulnerable to Denial of Service. An HTTP request with a long body triggers an ERR_HTTP_HEADERS_SENT unhandled exception that crashes the proxy server. This is only possible when the proxy server sets headers in the proxy request using the proxyReq.setHeader function.

For a proxy server running on http://localhost:3000, the following curl request triggers the unhandled exception:

## Recommendation

Upgrade to version 1.18.1 or later
// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Checked 2026-11-07 at 03:16 UTC. The most recent advisory here was published 2020-09-04. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.