pypi package report

Is pyspark safe?

12 known vulnerabilities, worst severity CRITICAL.

// reach

9 direct dependencies

4 carry known advisories, worst CRITICAL

85 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

No published models are known to use this package.


cvss
9.9
critical

CVSS v3.1 base score out of 10

epss
1.1%
medium

chance of exploitation in 30 days, 66th percentile of all CVEs

xyz score
5.2
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-329j-jfvr-rhr6, the advisory selected below

// 12 advisories

GHSA-329j-jfvr-rhr6

CRITICALGitHub ratingCVE-2023-22946

In Apache Spark versions prior to versions 3.4.0 and 3.3.3, applications using spark-submit can specify a proxy-user to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications.

Update to Apache Spark 3.4.0, 3.3.3, or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
High

Checked 2026-11-06 at 22:42 UTC. The most recent advisory here was published 2026-09-02. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.