pypi package report

Is markdown2 safe?

4 known vulnerabilities, worst severity HIGH.

// reach

3 direct dependencies

1 carry known advisories, worst CRITICAL

19 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

No published models are known to use this package.


cvss
7.5
high

CVSS v3.1 base score out of 10

epss
2.3%
medium

chance of exploitation in 30 days, 84th percentile of all CVEs

xyz score
4.3
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-jr9p-r423-9m2r, the advisory selected below

// 4 advisories

GHSA-jr9p-r423-9m2r

HIGHGitHub ratingCVE-2021-26813

markdown2 >=1.0.1.18, fixed in 2.4.0, is affected by a regular expression denial of service vulnerability. If an attacker provides a malicious string, it can make markdown2 processing difficult or delayed for an extended period of time.

// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Checked 2026-11-06 at 20:41 UTC. The most recent advisory here was published 2022-04-21. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.