pypi package report

Is future safe?

1 known vulnerability, worst severity HIGH.

// reach

0 direct dependencies

none carry a known advisory

    99 packages depend on it

    an advisory here reaches each of them

    Create a free accountfor every dependency path, dependent and what to upgrade
    // ai model usage

    No published models are known to use this package.


    cvss
    7.5
    high

    CVSS v3.1 base score out of 10

    epss
    1.9%
    medium

    chance of exploitation in 30 days, 80th percentile of all CVEs

    xyz score
    4.4
    medium

    CyberXYZ composite out of 10

    fig. 01 — GHSA-v3c5-jqr6-7qm8, the advisory selected below

    // 1 advisories

    GHSA-v3c5-jqr6-7qm8

    HIGHGitHub ratingCVE-2022-40899

    An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.

    // cvss v3.1 vector

    CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

    Attack vector
    Network
    Attack complexity
    Low
    Privileges required
    None
    User interaction
    None
    Scope
    Unchanged
    Confidentiality
    None
    Integrity
    None
    Availability
    High

    Checked 2026-11-06 at 23:10 UTC. The most recent advisory here was published 2022-12-23. Updated continuously from NVD, GHSA, OSV and CNA feeds.

    Think a verdict here is wrong? Tell us — we respond within 2 business days.