pypi package report

Is dbt-core safe?

4 known vulnerabilities, worst severity HIGH.

// reach

26 direct dependencies

9 carry known advisories, worst CRITICAL

40 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

No published models are known to use this package.


cvss
7.5
high

CVSS v3.1 base score out of 10

epss
not scored

chance of exploitation in 30 days

xyz score
4.3
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-p72q-h37j-3hq7, the advisory selected below

// 4 advisories

GHSA-p72q-h37j-3hq7

HIGHGitHub rating
// summary

Using a version of sqlparse that has a security vulnerability and no way to update in current version of dbt core. Snyk recommends using sqlparse==0.5 but this causes a conflict with dbt. Snyk states the issues is a recursion error: SNYK-PYTHON-SQLPARSE-6615674.

// details

Dependency conflict error message:

The conflict is caused by:
    The user requested sqlparse==0.5
    dbt-core 1.7.10 depends on sqlparse<0.5 and >=0.2.3

Resolution was to pin sqlparse >=0.5.0, <0.6.0 in dbt-core, patched in 1.6.13 and 1.7.13.

// poc

From Snyk:

import sqlparse
sqlparse.parse('[' * 10000 + ']' * 10000)
// impact

Snyk classifies it as high 7.5/10.

// patches

The bug has been fixed in dbt-core v1.6.13 and dbt-core v1.7.13.

// mitigations

Bump dbt-core 1.6 and 1.7 dependencies to 1.6.13 and 1.7.13 respectively

// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Checked 2026-11-06 at 21:55 UTC. The most recent advisory here was published 2024-07-17. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.