pypi package report

Is apache-airflow-providers-common-sql safe?

1 known vulnerability, worst severity HIGH.

// reach

13 direct dependencies

4 carry known advisories, worst CRITICAL

39 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

No published models are known to use this package.


cvss
8.8
high

CVSS v3.1 base score out of 10

epss
0.95%
medium

chance of exploitation in 30 days, 61st percentile of all CVEs

xyz score
4.3
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-5r62-mjf5-xwhj, the advisory selected below

// 1 advisories

GHSA-5r62-mjf5-xwhj

HIGHGitHub ratingCVE-2025-30473

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow Common SQL Provider.

When using the partition clause in SQLTableCheckOperator as parameter (which was a recommended pattern), Authenticated UI User could inject arbitrary SQL command when triggering DAG exposing partition_clause to the user. This allowed the DAG Triggering user to escalate privileges to execute those arbitrary commands which they normally would not have.

This issue affects Apache Airflow Common SQL Provider: before 1.24.1.

Users are recommended to upgrade to version 1.24.1, which fixes the issue.

// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Checked 2026-11-06 at 21:34 UTC. The most recent advisory here was published 2025-04-07. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.