npm package report

Is uglify-js safe?

2 known vulnerabilities, worst severity CRITICAL.

// reach

6 direct dependencies

1 carry known advisories, worst HIGH

60 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


cvss
9.8
critical

CVSS v3.1 base score out of 10

epss
3.6%
medium

chance of exploitation in 30 days, 89th percentile of all CVEs

xyz score
5.7
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-34r7-q49f-h37c, the advisory selected below

// 2 advisories

GHSA-34r7-q49f-h37c

CRITICALGitHub ratingCVE-2015-8857

Versions of uglify-js prior to 2.4.24 are affected by a vulnerability which may cause crafted JavaScript to have altered functionality after minification.

// recommendation

Upgrade UglifyJS to version >= 2.4.24.

// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Checked 2026-11-06 at 20:55 UTC. The most recent advisory here was published 2017-10-24. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.