npm package report

Is papaparse safe?

1 known vulnerability, worst severity HIGH.

// reach

0 direct dependencies

none carry a known advisory

    80 packages depend on it

    an advisory here reaches each of them

    Create a free accountfor every dependency path, dependent and what to upgrade
    // ai model usage

    Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


    cvss
    7.5
    high

    CVSS v3.1 base score out of 10

    epss
    1.4%
    medium

    chance of exploitation in 30 days, 73rd percentile of all CVEs

    xyz score
    4.4
    medium

    CyberXYZ composite out of 10

    fig. 01 — GHSA-qvjc-g5vr-mfgr, the advisory selected below

    // 1 advisories

    GHSA-qvjc-g5vr-mfgr

    HIGHGitHub ratingCVE-2020-36649

    Versions of papaparse prior to 5.2.0 are vulnerable to Regular Expression Denial of Service (ReDos). The parse function contains a malformed regular expression that takes exponentially longer to process non-numerical inputs. This allows attackers to stall systems and lead to Denial of Service.

    // recommendation

    Upgrade to version 5.2.0 or later.

    // cvss v3.1 vector

    CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

    Attack vector
    Network
    Attack complexity
    Low
    Privileges required
    None
    User interaction
    None
    Scope
    Unchanged
    Confidentiality
    None
    Integrity
    None
    Availability
    High

    Checked 2026-11-07 at 09:19 UTC. The most recent advisory here was published 2020-09-04. Updated continuously from NVD, GHSA, OSV and CNA feeds.

    Think a verdict here is wrong? Tell us — we respond within 2 business days.