npm package report

Is lodash-es safe?

6 known vulnerabilities, worst severity CRITICAL.

// reach

0 direct dependencies

none carry a known advisory

    256 packages depend on it

    an advisory here reaches each of them

    Create a free accountfor every dependency path, dependent and what to upgrade
    // ai model usage

    Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


    cvss
    9.1
    critical

    CVSS v3.1 base score out of 10

    epss
    5.0%
    medium

    chance of exploitation in 30 days, 92nd percentile of all CVEs

    xyz score
    5.5
    medium

    CyberXYZ composite out of 10

    fig. 01 — GHSA-jf85-cpcp-j695, the advisory selected below

    // 6 advisories

    GHSA-jf85-cpcp-j695

    CRITICALGitHub ratingCVE-2019-10744

    Versions of lodash before 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep allows a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects.

    // recommendation

    Update to version 4.17.12 or later.

    // cvss v3.1 vector

    CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

    Attack vector
    Network
    Attack complexity
    Low
    Privileges required
    None
    User interaction
    None
    Scope
    Unchanged
    Confidentiality
    None
    Integrity
    High
    Availability
    High

    Checked 2026-11-06 at 20:26 UTC. The most recent advisory here was published 2026-04-01. Updated continuously from NVD, GHSA, OSV and CNA feeds.

    Think a verdict here is wrong? Tell us — we respond within 2 business days.