npm package report

Is eslint-utils safe?

1 known vulnerability, worst severity CRITICAL.

// reach

0 direct dependencies

none carry a known advisory

    19 packages depend on it

    an advisory here reaches each of them

    • eslint
    • eslint-plugin-ava
    Create a free accountfor every dependency path, dependent and what to upgrade
    // ai model usage

    Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


    cvss
    9.8
    critical

    CVSS v3.0 base score out of 10

    epss
    2.3%
    medium

    chance of exploitation in 30 days, 83rd percentile of all CVEs

    xyz score
    5.2
    medium

    CyberXYZ composite out of 10

    fig. 01 — GHSA-3gx7-xhv7-5mx3, the advisory selected below

    // 1 advisories

    GHSA-3gx7-xhv7-5mx3

    CRITICALGitHub ratingCVE-2019-15657

    Versions of eslint-utils >=1.2.0 or <1.4.1 are vulnerable to Arbitrary Code Execution. The getStaticValue does not properly sanitize user input allowing attackers to supply malicious input that executes arbitrary code during the linting process. The getStringIfConstant and getPropertyName functions are not affected.

    // recommendation

    Upgrade to version 1.4.1 or later.

    // cvss v3.0 vector

    CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

    Attack vector
    Network
    Attack complexity
    Low
    Privileges required
    None
    User interaction
    None
    Scope
    Unchanged
    Confidentiality
    High
    Integrity
    High
    Availability
    High

    Checked 2026-11-06 at 21:59 UTC. The most recent advisory here was published 2019-08-26. Updated continuously from NVD, GHSA, OSV and CNA feeds.

    Think a verdict here is wrong? Tell us — we respond within 2 business days.