npm package reportIs concat-stream safe?
1 known vulnerability, worst severity MODERATE.
// reach6 direct dependencies
none carry a known advisory
62 packages depend on it
an advisory here reaches each of them
// ai model usageTracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.
cvssseverity band, no base score published
epsschance of exploitation in 30 days
xyz scoreCyberXYZ composite out of 10
fig. 01 — GHSA-g74r-ffvr-5q9f, the advisory selected below
// 1 advisories
GHSA-g74r-ffvr-5q9f
MODERATEGitHub ratingVersions of concat-stream before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into write()
Versions <1.3.0 are not affected due to not using unguarded Buffer constructor.
// recommendationUpdate to version 1.5.2, 1.4.11, 1.3.2 or later.
If you are unable to update make sure user provided input into the write() function is not a number.
Checked 2026-11-06 at 22:03 UTC. The most recent advisory here was published 2019-06-03. Updated continuously from NVD, GHSA, OSV and CNA feeds.