npm package report

Is bower safe?

1 known vulnerability, worst severity HIGH.

// reach

67 direct dependencies

17 carry known advisories, worst CRITICAL

9 packages depend on it

an advisory here reaches each of them

Create a free accountfor every dependency path, dependent and what to upgrade
// ai model usage

Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.


cvss
7.5
high

CVSS v3.1 base score out of 10

epss
2.6%
medium

chance of exploitation in 30 days, 85th percentile of all CVEs

xyz score
4.2
medium

CyberXYZ composite out of 10

fig. 01 — GHSA-p6mr-pxg4-68hx, the advisory selected below

// 1 advisories

GHSA-p6mr-pxg4-68hx

HIGHGitHub ratingCVE-2019-5484

Versions of bower prior to 1.8.8 are affected by an arbitrary file write vulnerability. The vulnerability occurs because bower does not verify that extracted symbolic links do not resolve to targets outside of the extraction root directory.

// recommendation

Update to version 1.8.8 or later

// cvss v3.1 vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None

Checked 2026-11-06 at 21:31 UTC. The most recent advisory here was published 2019-09-17. Updated continuously from NVD, GHSA, OSV and CNA feeds.

Think a verdict here is wrong? Tell us — we respond within 2 business days.