Tracked for PyPI packages. HuggingFace models declare Python dependencies, so npm packages are not covered.
cvss
6.5
medium
CVSS v3.1 base score out of 10
epss
not scored
chance of exploitation in 30 days
xyz score
not scored
CyberXYZ composite out of 10
fig. 01 — GHSA-2ggq-vfcp-gwhj, the advisory selected below
// 1 advisories
GHSA-2ggq-vfcp-gwhj
MODERATEGitHub rating
Versions of @hapi/boom prior to 0.3.8 are vulnerable to Cross-Site Scripting (XSS). The package fails to properly escape error messages, which may allow attackers to execute arbitrary JavaScript in a victim's browser.
// recommendation
Upgrade to version 0.3.8 or later.
// cvss v3.1 vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None
Checked 2026-11-07 at 17:16 UTC. The most recent advisory here was published 2020-09-04. Updated continuously from NVD, GHSA, OSV and CNA feeds.